Service Disruption
Incident Report for Searchie
Resolved
This incident has been resolved.
Posted Aug 30, 2021 - 08:42 UTC
Investigating
We are currently experiencing a service disruption.
Our team is working to identify the root cause and implement a solution.
Posted Aug 27, 2021 - 14:29 UTC
This incident affected: Searchie Website.