Service Disruption
Incident Report for Searchie
Resolved
This incident has been resolved.
Posted Apr 14, 2021 - 11:57 UTC
Investigating
We are currently experiencing a service disruption.
Our team is working to identify the root cause and implement a solution.
Posted Apr 14, 2021 - 11:40 UTC
This incident affected: Player.