Service disruption on Searchie Public Hubs
Incident Report for Searchie
Resolved
This incident has been resolved.
Posted Feb 16, 2022 - 17:31 UTC
Investigating
We are currently experiencing a service disruption. Our team is working to identify the root cause and implement a solution.
Posted Feb 16, 2022 - 17:06 UTC
This incident affected: Public Hubs.