Service disruption on Searchie website (www.searchie.io)
Incident Report for Searchie
Resolved
This incident has been resolved.
Posted May 01, 2023 - 04:58 UTC
Investigating
We are currently experiencing a service disruption. Our team is working to identify the root cause and implement a solution.
Posted May 01, 2023 - 04:56 UTC
This incident affected: Searchie Website.